We are investigating reports of slow response times from our Teamwork API
Incident Report for Teamwork.com
Resolved
A number of services received more traffic that usual and needed some time to scale up to meet the increased traffic demands. Response times have returned to normal and we will continue to monitor for performance issues.
Posted Mar 18, 2021 - 17:49 UTC
Investigating
We are investigating reports of slow response times from our Teamwork API
Posted Mar 18, 2021 - 17:11 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Launchpad (Launchpad - US Region), and Teamwork Chat (Teamwork Chat - US Region).