Desk application is degraded in US and EU regions

Incident Report for Teamwork.com

Resolved

this incident has been resolved
Posted Sep 04, 2023 - 09:46 UTC

Investigating

We are currently investigating this issue.
Posted Sep 04, 2023 - 09:01 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).