Loading issues
Incident Report for Teamwork.com
Resolved
All systems are fully operational. Thanks for your patience
Posted Aug 25, 2021 - 12:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2021 - 12:12 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2021 - 12:07 UTC
Update
We are continuing to investigate this issue.
Posted Aug 25, 2021 - 12:04 UTC
Investigating
We are seeing some load issues at the moment - investigating
Posted Aug 25, 2021 - 12:03 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).