We are investigating reports of slow response times for Teamwork Chat in our US region
Incident Report for Teamwork.com
Resolved
Response times of Teamwork Chat are back to normal now after reverting some earlier work.
Posted Dec 08, 2020 - 17:56 UTC
Monitoring
We have deployed a fix for a routing issue that was impacting on performance. We continue to monitor to bring response times back to normal.
Posted Dec 08, 2020 - 16:59 UTC
Investigating
We are investigating reports of slow response times for Teamwork Chat in our US region
Posted Dec 08, 2020 - 15:13 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).