We are investigating reports of errors appearing on screen in Teamwork in our US region
Incident Report for Teamwork.com
Resolved
We have rolled back a deployment which was using up a little too much memory at peak traffic, triggering errors for some users in our US region.
Posted Jan 24, 2020 - 21:07 UTC
Investigating
We are investigating reports of errors appearing on screen in Teamwork in our US region
Posted Jan 24, 2020 - 19:51 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).