We are investigating reports of users unable to create new accounts at teamwork.com
Incident Report for Teamwork.com
Resolved
We have reverted some recently security measures we recently deployed, allowing sign ups to progress fully again.
Posted Jul 03, 2020 - 20:19 UTC
Investigating
We are investigating reports of users unable to create new accoutns at teamwork.com
Posted Jul 03, 2020 - 19:15 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region).