Issue loading Projects and Tasks for a subset of customers in the US Region.
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Apr 05, 2022 - 12:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2022 - 12:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 05, 2022 - 12:07 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).