we are investigating reports of issues with Teamwork Desk in our EU region
Incident Report for Teamwork.com
Resolved
Teamwork Desk in our EU region remains stable and we will monitor for any issues
Posted Dec 18, 2019 - 11:13 UTC
Investigating
We are currently investigating this issue.
Posted Dec 18, 2019 - 08:44 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).