We are investigating reports of slow downs on Desk in our EU region
Incident Report for Teamwork.com
Resolved
Desk in our EU region is running smoothly now
Posted Sep 13, 2019 - 09:16 UTC
Investigating
We are investigating reports of slow downs on Desk in our EU region
Posted Sep 13, 2019 - 09:06 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).