We are currently investigating issues with Teamwork in our US region
Incident Report for Teamwork.com
Resolved
A small number of database replicas became corrupted overnight and were replaced.
Posted Feb 16, 2022 - 08:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2022 - 06:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 16, 2022 - 06:08 UTC
Investigating
We are currently investigating connectivity issues with Teamwork products In our US region.
Posted Feb 16, 2022 - 05:46 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region), Teamwork Projects (Teamwork Projects - US region), Teamwork CRM (Teamwork CRM - US region), Teamwork Spaces (Teamwork Spaces - US Region), Launchpad (Launchpad - US Region), and Teamwork Chat (Teamwork Chat - US Region).