We are currently investigating issues with Projects in the US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 00:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 00:16 UTC
Update
Engineers have identified the core issue is an isolated API endpoint failing - close to a resolution and hope to be back online soon
Posted Jul 17, 2024 - 00:09 UTC
Investigating
We are currently investigating this issue.
Posted Jul 16, 2024 - 23:22 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).