We are inviestigating reports of slow loading times in our US region
Incident Report for Teamwork.com
Resolved
We experienced some intermittent slow downs in our US region which has passed and services are operating normally.
Posted Apr 16, 2020 - 16:00 UTC
Investigating
We are inviestigating reports of slow loading times in our US region
Posted Apr 16, 2020 - 15:09 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).