Unexpected Teamwork Desk & Chat disruption in the US region

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 17:42 UTC

Monitoring

We identified the root cause and deployed a mitigation fix. We are now monitoring to ensure services restore fully for all customers affected.
Posted Aug 14, 2025 - 17:12 UTC

Investigating

We are currently investigating an unexpected infrastructure issue affecting users of Teamwork Desk & Teamwork Chat in the US region.
Posted Aug 14, 2025 - 16:40 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Chat (Teamwork Chat - US Region).