Slow load timw

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 05:30 UTC

Investigating

We are currently seeing some slow loading across Teamwork Desk, Spaces and Chat.
Posted Jun 30, 2025 - 15:21 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Desk (Teamwork Desk - US Region), Teamwork Chat (Teamwork Chat - US Region), and Teamwork Spaces (Teamwork Spaces - US Region).