Load issues with Teamwork

Incident Report for Teamwork.com

Resolved

Everything is back up and running as expected. Thanks for your patience.
Posted Dec 08, 2025 - 19:11 UTC

Investigating

We are currently seeing load issue with Teamwork. We are investigating and hope to have everything back to normal as soon as possible.
Posted Dec 08, 2025 - 16:32 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region).