Teamwork Desk Mail Processing

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 09:15 UTC

Monitoring

Teamwork Desk experienced an issue earlier today that caused delays in email processing. The issue has now been resolved, and mail is currently processing as normal.

Please note that there will still be some delays in messages received over the past few hours. We’re continuing to monitor the system closely
Posted Jun 26, 2025 - 13:38 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).