We are investigating reports of connectivity issues for Teamwork Chat in our US region
Incident Report for Teamwork.com
Resolved
Connectivity issues have been resolved now in our US region. Users currently logged in to Chat might need to reload in order to reconnect properly.
Posted Apr 28, 2021 - 12:09 UTC
Investigating
We are investigating reports of connectivity issues for Teamwork Chat in our US region
Posted Apr 28, 2021 - 11:57 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).