Load issues
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted May 31, 2022 - 17:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2022 - 14:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 31, 2022 - 14:09 UTC
Update
We are continuing to investigate this issue.
Posted May 31, 2022 - 13:59 UTC
Investigating
We are currently seeing some load issues for Teamwork Projects and Desk, we are currently investigating
Posted May 31, 2022 - 13:58 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region, Teamwork Projects - AU region).