Degraded performance Teamwork Desk
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 08:44 UTC
Monitoring
A fix has been deployed, and we are monitoring. Thanks for your patience.
Posted Nov 26, 2024 - 22:14 UTC
Update
We are continuing to investigate this issue.
Posted Nov 26, 2024 - 20:45 UTC
Investigating
We are currently seeing some degraded performance with Teamwork Desk, we are currently investigating.
Posted Nov 26, 2024 - 20:13 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).