Services have now been restored following earlier remediation work. Our Engineering team will continue to monitor service closely over the coming hours.
Posted 1 year ago. Feb 26, 2024 - 18:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Feb 26, 2024 - 17:37 UTC
Update
Over the past number of hours our Engineering team have observed abnormally high levels of traffic to core services. We have have taken a number of steps to restore full service including scaling these service both horizontally and vertically. We're continuing to monitor the impact of these changes to restore services.
Posted 1 year ago. Feb 26, 2024 - 16:31 UTC
Update
We are still working on a fix for this issue. The cause was identified and a fix is underway.
Posted 1 year ago. Feb 26, 2024 - 14:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 1 year ago. Feb 26, 2024 - 13:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Feb 26, 2024 - 12:44 UTC
Investigating
We are currently experiencing connectivity issues with all products In our US Region.
Posted 1 year ago. Feb 26, 2024 - 12:43 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Desk (Teamwork Desk - US Region), Teamwork Chat (Teamwork Chat - US Region), and Teamwork Spaces (Teamwork Spaces - US Region).