Teamwork Projects & Desk US region loading issues

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 18:28 UTC

Monitoring

We identified the issue as being caused by an unexpected failover in a 3rd party service. Teamwork.com services recovered quickly and we'll continue to monitor for any remaining customer impact over the next few hours.
Posted Jul 07, 2025 - 16:33 UTC

Investigating

We're investigating an issue in our infrastructure which is causing loading issues for customers in the US region.
Posted Jul 07, 2025 - 16:10 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region) and Teamwork Desk (Teamwork Desk - US Region).