We are experiencing intermittent connectivity issues in our US region due to an up stream provider
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 18:58 UTC
Monitoring
We have mitigated the impact of the upstream issues and waiting for the provider to fully resolve them
Posted Apr 19, 2022 - 17:04 UTC
Identified
We are experiencing intermittent connectivity issues in our US region due to an up stream provider
Posted Apr 19, 2022 - 16:01 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Desk (Teamwork Desk - US Region), and Teamwork Chat (Teamwork Chat - US Region).