We are experiencing connectivity issues in the EU region.
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted May 22, 2020 - 10:06 UTC
Update
We are continuing to monitor for any further issues.
Posted May 22, 2020 - 09:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2020 - 09:57 UTC
Investigating
We are currently investigating this issue.
Posted May 22, 2020 - 08:53 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - EU Region).