We are currently experiencing issues with Teamwork Chat in our US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 18:57 UTC
Update
We had a follow on incident in one of our caches resulting from an earlier database being under pressure. This has now passed and the apps are stable again.
Posted Sep 21, 2020 - 17:04 UTC
Identified
We are currently experiencing issues with Teamwork Chat in our US region
Posted Sep 21, 2020 - 16:41 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).