Desk unavailable
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 03, 2019 - 09:39 UTC
Update
This incident is also impacting US Desk. Problem has been identified and should be fixed shortly
Posted 17 days ago. Oct 03, 2019 - 08:56 UTC
Identified
Our engineers are actively working on this problem
Posted 17 days ago. Oct 03, 2019 - 08:51 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).