We are receiving reports of sites not loading for Teamwork Desk in our EU region
Incident Report for Teamwork.com
Resolved
We have rolled back a recent deployment for Teamwork Desk in our EU region and are investigating
Posted Nov 12, 2019 - 15:12 UTC
Investigating
We are receiving reports of sites not loading for Teamwork Desk in our EU region
Posted Nov 12, 2019 - 14:52 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).