Desk Initial Load US region has failed
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Oct 24, 2022 - 18:34 UTC
Monitoring
A fix has been deployed and Teamwork Desk remains stable. We will continue to monitor.
Posted Oct 24, 2022 - 18:26 UTC
Identified
We have identified an issue and a fix is being deployed
Posted Oct 24, 2022 - 18:22 UTC
Update
We are continuing to investigate this issue.
Posted Oct 24, 2022 - 17:48 UTC
Investigating
We're currently investigating an issue with our service
Posted Oct 24, 2022 - 17:40 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).