We are investigting slow downs in our EU custom domain service
Incident Report for Teamwork.com
Resolved
Our custom domain service was under heavy load in the EU and is operating normally now
Posted Sep 12, 2019 - 10:28 UTC
Identified
We are investigting slow downs in our EU custom domain service
Posted Sep 12, 2019 - 10:23 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).