Desk not responding
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 03, 2019 - 10:33 UTC
Monitoring
fix applied. Desk is working again
Posted 17 days ago. Oct 03, 2019 - 10:33 UTC
Identified
Our engineers have identified a problem with US database and are currently working on a fix
Posted 17 days ago. Oct 03, 2019 - 10:04 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).