Degraded performance for new sign ups in our US region
Incident Report for Teamwork.com
Resolved
Database performance has remained stable for a period of time now so resolving this Status update
Posted Feb 16, 2022 - 13:14 UTC
Monitoring
We have replaced a damaged replica and are monitoring for further issues
Posted Feb 16, 2022 - 12:43 UTC
Investigating
We are currently investigating issues in the US region.
Posted Feb 16, 2022 - 12:12 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).