We are currently investigating reports of issues with Teamwork Projects in our US region
Incident Report for Teamwork.com
Resolved
Teamwork Projects is now stable, A small number of database replicas in the US region rebooted in a shot period of time due to a fault, causing our services to reconnect, resulting in poor performance in the Teamwork Projects app.
Posted Oct 24, 2019 - 11:19 UTC
Investigating
We are currently investigating reports of issues with Teamwork Projects in our US region
Posted Oct 24, 2019 - 10:31 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Projects (Teamwork Projects - US region).