We are investigating reports of slow downs for Teamwork Desk in our US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 17:38 UTC
Investigating
We are investigating reports of slow downs for Teamwork Desk in our US region
Posted Feb 06, 2020 - 15:51 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).