Desk mail processing issues
Incident Report for Teamwork.com
Resolved
This incident has been resolved
Posted May 01, 2023 - 23:19 UTC
Identified
The Issue has been identified and a fix implemented
Posted May 01, 2023 - 23:14 UTC
Investigating
We are currently investigating reports of mail processing issues
Posted May 01, 2023 - 22:28 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).