We have identified an issue with Spaces in our US region and are working to resolve it
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Dec 01, 2020 - 10:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 01, 2020 - 09:59 UTC
Investigating
We have identified an issue with Spaces in our US region and are working to resolve it
Posted Dec 01, 2020 - 09:59 UTC
This incident affected: Teamwork Spaces (Teamwork Spaces - US Region).