Projects connectivity issues
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted May 30, 2023 - 16:28 UTC
Monitoring
We are monitoring the results to ensure the applications are working as expected
Posted May 30, 2023 - 16:26 UTC
Identified
The issue has been identified and a fix put in place
Posted May 30, 2023 - 16:23 UTC
Investigating
We are currently investigating reports of a connectivity issues across both the US and EU regions.
Posted May 30, 2023 - 16:19 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region).