Connectivity issues with Projects in the US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 10:24 UTC
Identified
Service has been restored and we are monitoring the situation
Posted Feb 12, 2021 - 10:13 UTC
Investigating
We are currently investigating connectivity issues with Projects in the US region
Posted Feb 12, 2021 - 10:06 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).