Connectivity issues in our US region due to an upstream provider
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 21:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2021 - 20:32 UTC
Update
AWS services are being restored and we are close to resolving the issues to our customers caused by those outages
Posted Dec 22, 2021 - 20:01 UTC
Update
We are still waiting for Amazon Web Services to restore service and are attempting to mitigate the issues for affected users
Posted Dec 22, 2021 - 14:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 22, 2021 - 13:49 UTC
Identified
The issue has been traced back to an Amazon Web Service outage.
Posted Dec 22, 2021 - 13:31 UTC
Investigating
We are currently investigating this issue.
Posted Dec 22, 2021 - 12:26 UTC
This incident affected: Launchpad (Launchpad - US Region), Teamwork CRM (Teamwork CRM - US region), Teamwork Projects (Teamwork Projects - US region), Teamwork Desk (Teamwork Desk - US Region), Teamwork Spaces (Teamwork Spaces - US Region), and Teamwork Chat (Teamwork Chat - US Region).