Load issues with Teamwork Chat

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted 2 months ago. Feb 10, 2025 - 17:41 UTC

Investigating

We are seeing some loading issues for some users on Teamwork Chat, the team here are looking into this and all will be back to normal really soon.
Posted 2 months ago. Feb 10, 2025 - 17:18 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).