Outbound email issues
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Feb 14, 2023 - 14:56 UTC
Monitoring
A workaround has been implemented to bypass the issue we've been experiencing with our outbound email service. Email is processing successfully again and our engineers continue to monitor the service.
Posted Feb 13, 2023 - 16:52 UTC
Update
Issue escalated with our mail provider
Posted Feb 13, 2023 - 13:33 UTC
Investigating
We're investigating issues with Outbound email
Posted Feb 13, 2023 - 08:44 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region).