We are investigating reports of slow downs in our US region
Incident Report for Teamwork.com
Resolved
We have rolled back a failed deployment to our routing application in the US region.
Posted 14 days ago. Sep 09, 2019 - 13:01 UTC
Investigating
We are investigating reports of slow downs in our US region
Posted 14 days ago. Sep 09, 2019 - 12:52 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Projects (Teamwork Projects - US region).