Teamwork Projects unresponsive browser tabs issue

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 15:20 UTC

Monitoring

We've released a fix which to resolve the issue. We'll continue to monitor to ensure all affected customers are unblocked.
Posted Jul 07, 2025 - 14:54 UTC

Identified

We have identified the root cause of the issue and are working to release a fix shortly.
Posted Jul 07, 2025 - 14:40 UTC

Update

We are continuing to investigate this issue.
Posted Jul 07, 2025 - 14:13 UTC

Investigating

We are currently investigating reports of browser tabs taking a long time to load or freezing up.
Posted Jul 07, 2025 - 14:11 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region).