We are investigating connection issues for Desk in our US region
Incident Report for Teamwork.com
Resolved
Some maintenance being performed to a Redis cache caused Desk to respond slowly for a minute while the maintenance completed.
Posted Jun 18, 2020 - 12:05 UTC
Investigating
We are investigating connection issues for Desk in our US region
Posted Jun 18, 2020 - 12:01 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).