We are currently experiencing a high level of traffic in our US region impacting on performance
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 07:24 UTC
Monitoring
We have scaled up to handle the current traffic and performance has returned to normal levels. We will continue to monitor
Posted Sep 08, 2021 - 06:55 UTC
Identified
We are currently experiencing a high level of traffic in our US region impacting on performance
Posted Sep 08, 2021 - 06:39 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Projects (Teamwork Projects - US region).