We are investigating reports of slow response times from Teamwork in our US region

Incident Report for Teamwork.com

Resolved

A small number of our database replicas in the US region were experiencing lag due to high usage, which has now been resolved.
Posted Jan 15, 2020 - 20:09 UTC

Identified

We are investigating reports of slow response times from Teamwork in our US region
Posted Jan 15, 2020 - 19:28 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).