We are currently investigating issues with Chat in our US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 17:57 UTC
Investigating
We are currently investigating connectivity issues with all products in our US Regions.
Posted Aug 18, 2020 - 17:25 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Spaces (Teamwork Spaces - US Region), Launchpad (Launchpad - US Region), Teamwork CRM (Teamwork CRM - US region), Teamwork Chat (Teamwork Chat - US Region), and Teamwork Desk (Teamwork Desk - US Region).