Teamwork Projects - Service Degradation.

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 23:08 UTC

Investigating

We're currently investigating reports of slow loading times for tasks and timesheets.
Posted Jan 14, 2026 - 22:32 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).