We are experiencing intermittent issues when opening and replying to tickets in the US region.
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Jun 28, 2023 - 12:33 UTC
Update
We are continuing to monitor the fix for any further issues.
Posted Jun 28, 2023 - 09:17 UTC
Update
We are continuing to monitor the fix for any further issues.
Posted Jun 28, 2023 - 07:05 UTC
Update
We are continuing to roll out the fix and as of now the majority of scenarios should be covered. There may be some residual errors being closely monitored.
Posted Jun 27, 2023 - 23:13 UTC
Monitoring
We have begun a controlled deployment of a fix and are continuing to monitor its progress
Posted Jun 27, 2023 - 19:14 UTC
Identified
The issue has been identified and a fix is being implemented. We are still accessing how long the fix will take to fully implement.
Posted Jun 27, 2023 - 16:34 UTC
Investigating
We are currently investigating the issues.
Posted Jun 27, 2023 - 15:36 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).