We are currently investigating database connectivity issues in EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 16:32 UTC
Investigating
We are currently investigating this issue.
Posted Jan 15, 2021 - 15:18 UTC
This incident affected: Teamwork CRM (Teamwork CRM - EU Region), Teamwork Desk (Teamwork Desk - EU Region), Teamwork Projects (Teamwork Projects - EU Region), Teamwork Spaces (Teamwork Spaces - EU Region), Launchpad (Launchpad - EU Region), and Teamwork Chat (Teamwork Chat - EU Region).