We are investigating reports of slow response times from Teamwork in our US region
Incident Report for Teamwork.com
Resolved
One of our databases received a higher than usual number of connections, we have identified the source and brought levels back to normal now.
Posted Jun 01, 2021 - 15:25 UTC
Investigating
We are investigating reports of slow response times from Teamwork in our US region
Posted Jun 01, 2021 - 13:42 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Projects (Teamwork Projects - US region).