We are investigating reports of slow downs for Teamwork Desk in our US region
Incident Report for Teamwork.com
Resolved
We have identified the cause of the slow response times in Teamwork Desk in our US region. The development team have deployed an update and response times have improved significantly as a result.
Posted Feb 05, 2020 - 18:38 UTC
Identified
We are investigating reports of slow downs for Teamwork Desk in our US region
Posted Feb 05, 2020 - 17:02 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).